Back
Downtime

Synctera Cases is unavailable
Started 9 May at 09:18am PDT, resolved 9 May at 09:22am PDT.
https://app.synctera.com
Resolved
Our Cases functionality is back to normal.
This issue was related to an underlying Google Cloud Platform incident.
Posted 9 May at 09:22am PDT.

Created
Our Cases functionality is currently experiencing a production outage. As such, cases cannot be viewed via the Synctera Console.
Other aspects of our platform are not impacted.
Posted 9 May at 09:18am PDT.