Resolved
The state of the permission system has been restored, access is back up.
Identified
Root cause has been identified, the fix is being rolled out and access should be restored soon.
Investigating
Permission enforcement is broken across all of sandbox, access over API key or console is currently down.